Fehler „Could not find any notifications for this transaction.“ beim Transaktionsimport

  • Aktualisiert

Die Fehlermeldung „Could not find any notifications for this transaction.“ kann beim Import einer Transaktion in collana pay auftreten. Der Fehler tritt typischerweise auf, wenn im Request der Parameter notificationRequired: true gesetzt wurde, jedoch keine zugehörigen Notifications für die Transaktion vorhanden sind. Ursache hierfür ist häufig eine fehlende Webhook-Konfiguration beim verwendeten Payment Service Provider (PSP).

Fehlermeldung

Could not find any notifications for this transaction.

Ursache

Der Importprozess erwartet eine Notification zur jeweiligen Transaktion, sobald notificationRequired: true im Request verwendet wird. Sind keine Notifications bei collana pay vorhanden, kann die Transaktion nicht verarbeitet werden. Dies tritt beispielsweise auf, wenn beim PSP keine Webhooks eingerichtet wurden oder keine Benachrichtigungen an collana pay gesendet werden.

Der notificationRequired-Modus ist dafür gedacht, Importe von Transaktionen zu validieren, um Importe von Transaktionen mit Betragsabweichungen (z. B. Cent-Abweichungen durch unterschiedliche Berechnungen) direkt vor dem Import abzulehnen.

Lösung

  1. Prüfen, ob der Parameter notificationRequired: true im Request enthalten und zwingend erforderlich ist.

  2. Falls keine Notification-Verarbeitung benötigt wird, den Parameter notificationRequired aus dem Request entfernen.

  3. Falls Notifications erforderlich sind, die Webhook-Konfiguration beim verwendeten PSP prüfen.

  4. Sicherstellen, dass der PSP Notifications für Transaktionen an collana pay übermittelt.

  5. Nach Anpassung der Konfiguration den Import der Transaktion erneut durchführen.